CCR Push/Pull Outage Unavailable in Multiple Regions

Incident Report for Crusoe Cloud

Resolved

This issue has been resolved. Please contact support@crusoe.ai if you are still experiencing any issues.
Posted Feb 02, 2026 - 04:38 UTC

Investigating

Customers using  CCR (Crusoe Container Registry ) will be unable to push or pull images in us-east1, eu-iceland1 and us-southcentral1. We are working on resolving this matter as soon as possible.  If you experience any other issues, please reach out to support@crusoe.ai
Posted Feb 01, 2026 - 21:42 UTC
This incident affected: Storage (Container Registry).