Crusoe Managed Kubernetes Outage

Incident Report for Crusoe Cloud

Resolved

This incident has now been resolved
Posted Mar 27, 2025 - 23:04 UTC

Monitoring

A fix has been implemented, and we are monitoring the systems
Posted Mar 27, 2025 - 22:28 UTC

Investigating

We are currently experiencing a significant disruption to one of our shared infrastructure services, which is impacting resource creation and kubeconfig retrieval across all datacenter regions for our CMK product. Any existing workloads will not be impacted.
Posted Mar 27, 2025 - 20:14 UTC
This incident affected: Orchestration (Crusoe Managed Kubernetes (CMK)).