Disruption to Cluster Management Services in us-southcentral Region

Incident Report for Crusoe Cloud

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 21:25 UTC

Update

We are pleased to report that this incident is now resolved. We have confirmed that control plane functionality for all impacted clusters in the us-southcentral region has been fully restored.

The issue was caused by network congestion on a small number of underlying physical hosts. This has been remediated by isolating the source of the traffic. We will be conducting a full post-mortem to prevent a recurrence and apologize for any disruption this incident caused.
Posted Mar 04, 2026 - 21:25 UTC

Investigating

We are investigating an issue in our US-Southcentral region that may be impacting the ability to manage cluster resources via the API. Our engineering team is actively working to identify the scope and cause. We will provide another update as more information becomes available.
Posted Mar 04, 2026 - 19:36 UTC
This incident affected: API (API).