Load Balancer Connectivity Degradation — Iceland Region

Incident Report for Crusoe Cloud

Resolved

This incident has been resolved.
Posted Jun 17, 2026 - 01:17 UTC

Update

The issue was identified and resolved as of approximately 15:45 PDT. Load balancer connectivity in the ICAT region has been restored.
Posted Jun 17, 2026 - 01:17 UTC

Investigating

Beginning at approximately 13:55 PDT, load balancers in the ICAT region became unreachable. Customers relying on load balancer endpoints in this region may be experiencing connectivity failures.

Our team is actively investigating and working to restore service. We will provide updates as more information becomes available.
Posted Jun 16, 2026 - 21:15 UTC
This incident affected: Networking (Datacenter Networking).