Iceland - Elevated Shared Disk Write Latency

Incident Report for Crusoe Cloud

Resolved

This issue has been resolved.
Posted May 26, 2026 - 00:26 UTC

Identified

We are seeing an improvement in latency and our teams remain fully focused on driving further recovery. We will provide an update as soon as we have more information available.
Posted May 25, 2026 - 15:15 UTC

Update

We are continuing to investigate this issue.
Posted May 25, 2026 - 14:28 UTC

Update

We are continuing to investigate this issue.
Posted May 25, 2026 - 13:08 UTC

Investigating

We are investigating an issue on the eu-iceland1-storage cluster. Customers may experience elevated write latency.
We will provide an update as soon as we have more information available.
Posted May 25, 2026 - 12:32 UTC
This incident affected: Storage (Shared Disks) and GPU Virtual Machines (eu-iceland1).