Custom Image Creation Impacted in Select Regions

Incident Report for Crusoe Cloud

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 11, 2026 - 16:51 UTC

Investigating

We have identified an issue affecting custom image creation in us-east1-a, us-southcentral1-a and eu-iceland1-a regions. We have identified the underlying cause and are actively working to restore service. We will provide more information as soon as possible.
Posted Jun 11, 2026 - 16:50 UTC
This incident affects: GPU Virtual Machines (us-east1, us-southcentral1, eu-iceland1).