Certain VM's in us-northcentral1-a are unavailable

Incident Report for Crusoe Cloud

Update

Our team is continuing its in-depth investigation into the intermittent storage connectivity issues impacting VM reachability in the us-northcentral1-a region, in collaboration with our vendor. We will keep you posted on further developments
Posted Jul 01, 2025 - 05:21 UTC

Update

We are continuing our in-depth investigation into the intermittent storage connectivity issues impacting VM reachability in the us-northcentral1-a region. We will provide more information as it becomes available.
Posted Jul 01, 2025 - 01:34 UTC

Update

Our teams are working diligently and believe we have identified the root cause and we are working on implementing a resolution. We will continue to provide updates on this page as further developments occur.
Posted Jun 30, 2025 - 22:01 UTC

Investigating

We are currently investigating a potential service interruption that may impact VMs to be unreachable in the us-northcentral1-a region. If you are experiencing issues in this region, please reach out to support@crusoecloud.com
Posted Jun 30, 2025 - 18:05 UTC
This incident affects: Storage (Persistent Storage).