Scheduled maintenance has been completed successfully. Container Registry is back to normal operation.
Posted Jul 01, 2026 - 06:00 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 01, 2026 - 04:00 UTC
Scheduled
Crusoe Cloud will be performing planned maintenance on the Crusoe Container Registry (CCR) in us-east1-a to improve reliability and performance. During the maintenance window, CCR in the us-east1-a region will be fully unavailable. We recommend pausing any workflows that depend on pushing or pulling container images until the window has concluded.
All other Crusoe Cloud services will remain operational. If you have questions regarding your specific workloads or notice persistent issues following the maintenance window, please reach out to support@crusoe.ai.
Posted Jun 30, 2026 - 21:10 UTC
This scheduled maintenance affected: Container Registry (Container Registry).