Control Plane Service Outage

Incident Report for Crusoe Cloud

Resolved

All Crusoe Cloud services have been restored and are fully operational. We will continue to monitor our platform. If you notice any issues please reach out to support@crusoecloud.com
Posted Jun 12, 2025 - 21:35 UTC

Monitoring

We're starting to see signs of recovery across affected services, and our team is monitoring the situation very closely.
Posted Jun 12, 2025 - 21:08 UTC

Update

We are expanding the scope of this incident to include the Crusoe console being inaccessible. This means that users are currently unable to log in, view, or manage resources through the Crusoe console interface. We are investigating this alongside the existing issues.
Posted Jun 12, 2025 - 20:16 UTC

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 20:06 UTC

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 20:03 UTC

Investigating

We are currently experiencing an outage with our 3rd party service provider, which is intermittently impacting the ability to provision and manage Virtual Machines (VMs) across all of our regions.
Posted Jun 12, 2025 - 19:55 UTC
This incident affected: GPU Virtual Machines (us-east1, us-northcentral1, us-southcentral1, eu-iceland1) and API, UI.