A subset of VMs are showing as UNSPECIFIED in our us-east2 region

Incident Report for Crusoe Cloud

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2026 - 10:51 UTC

Identified

We're currently investigating an issue affecting a subset of customer VMs in our us-east2 region . A subset of VMs are showing as UNSPECIFIED in our control plane . We have identified the issue and are actively working on fixing it to bring affected VMs back to a healthy state. We will provide more information as soon as it becomes available.
Posted Sep 09, 2026 - 09:56 UTC
This incident affects: GPU Virtual Machines (us-east2).