Project Creation Delays

Incident Report for Crusoe Cloud

Resolved

This incident has been resolved.
Posted May 09, 2026 - 03:09 UTC

Update

The issue has been mitigated and project creation requests are completing successfully.
Posted May 09, 2026 - 03:09 UTC

Investigating

We're investigating failures when creating new projects. Existing workloads and resources remain fully operational. We will provide an update when more information is available.
Posted May 08, 2026 - 20:04 UTC
This incident affected: API (API).