Custom Image Creation Issues in EU-Iceland

Incident Report for Crusoe Cloud

Resolved

This issue has been resolved. If you are still experiencing any other issues related to this matter, please contact support@crusoe.ai.
Posted Feb 04, 2026 - 00:12 UTC

Investigating

We are currently investigating reports of failures when creating Custom Images in our EU-Iceland (eu-iceland1-a) region.

Users may receive "Internal Server Errors" or experience operation timeouts when attempting to create Custom Images from existing disks. If you experience any other issues, please reach out to support@crusoe.ai.
Posted Feb 03, 2026 - 21:42 UTC