Kubernetes Cluster Authentication and Provisioning Degradation

Incident Report for Crusoe Cloud

Resolved

This incident has been resolved.
Posted Mar 18, 2026 - 23:30 UTC

Investigating

We are investigating an issue affecting Kubernetes CMK control plane operations. Customers may experience elevated latency or timeouts when retrieving cluster credentials via the CLI or console, and may be unable to create new clusters. Existing cluster workloads are not affected. We will provide a further update as our investigation continues.
Posted Mar 18, 2026 - 20:21 UTC
This incident affected: Orchestration (Crusoe Managed Kubernetes (CMK)).