Investigating Control Plane Failures in US-Southcentral

Incident Report for Crusoe Cloud

Resolved

This incident has been resolved.
Posted Jul 11, 2025 - 16:21 UTC

Monitoring

A fix has been applied and the outage has been mitigated. Services have returned to normal operations in US-Southcentral region. We are continuing to monitor the situation and validate preventive measures. Please contact support@crusoecloud.com if you are still experiencing any issues.
Posted Jul 11, 2025 - 15:32 UTC

Identified

We've identified a potential issue on the control plane network and we're working to address the issue currently.
Posted Jul 11, 2025 - 15:11 UTC

Investigating

We're currently investigating an issue impacting our control plane in the US-Southcentral region. Customers may experience errors or timeouts when making certain API calls, including those for creating new virtual machines.

Our engineering team is investigating the underlying cause with the highest priority. We appreciate your patience and will provide another update as soon as we have more information.
Posted Jul 11, 2025 - 14:28 UTC
This incident affected: API.