Crusoe Container Registry (CCR) Outage – TLS/Auth Errors in US South Central(us-southcentral1-a)

Incident Report for Crusoe Cloud

Update

We continue to investigate the issue and have narrowed down the root cause. Our team is actively working towards a resolution and will provide a further update as soon as possible.
Posted Jul 08, 2026 - 11:03 UTC

Investigating

We are investigating an issue affecting the Crusoe Container Registry (CCR) in the US South Central (us-southcentral1-a) region. Beginning at approximately 04:07 UTC on July 8, 2026, customers may be unable to push or pull container images, and may see TLS handshake timeouts or authentication errors.
Our engineering team is actively investigating. We will provide more information as we investigate the issue.
Posted Jul 08, 2026 - 05:23 UTC
This incident affects: Container Registry (Container Registry).