Partial outage in us-east1

Incident Report for Crusoe Cloud

Resolved

We are marking this incident as resolved. Please reach out to support@crusoecloud.com if you experience any issues.
Posted Jun 11, 2025 - 03:36 UTC

Monitoring

We have identified the issue and a fix has been implemented. Currently, there is no further impact expected to virtual machine accessibility. We are currently monitoring the environment.
Posted Jun 11, 2025 - 03:20 UTC

Investigating

We are currently investigating an issue impacting virtual machine accessibility. Some users may be unable to stop and start Virtual Machines.
Posted Jun 11, 2025 - 03:10 UTC
This incident affected: GPU Virtual Machines (us-east1).