CMK Customers unable to provision new block storage volumes

Incident Report for Crusoe Cloud

Resolved

This incident has been resolved.
Posted Apr 17, 2026 - 02:52 UTC

Investigating

We are currently investigating an issue specifically affecting Persistent Volume (PVC) creation for Crusoe Managed Kubernetes (CMK) customers. While this interruption prevents the provisioning of new block storage volumes, it is strictly limited to block storage and does not impact Shared Disks or other services. Existing volumes and active workloads remain fully operational and unaffected. Our engineering team has identified the root cause and is restoring the service. We expect to provide a final update once provisioning functionality is fully restored.
Posted Apr 17, 2026 - 01:30 UTC
This incident affected: Storage (Persistent Storage).