Storage Metrics Reporting Issue in the eu-iceland1 Region

Incident Report for Crusoe Cloud

Resolved

This incident has been resolved.
Posted May 06, 2026 - 23:41 UTC

Investigating

We are currently experiencing an issue with storage used disk capacity metrics in our Iceland (eu-iceland1) region.

All data access, read/write operations, and service functionality continue to operate normally with no performance impact. Our team is actively working to restore capacity metrics.  We will provide updates as restoration progresses.
Posted May 06, 2026 - 22:19 UTC
This incident affected: Storage (Shared Disks).