Shared Disks API operations issue in eu-iceland1-a region

Incident Report for Crusoe Cloud

Resolved

A fix has been implemented which fixed the issue. All operations should have resumed normally.
Posted Feb 20, 2026 - 15:21 UTC

Investigating

We are currently investigating an issue impacting our Shared Disks in the eu-iceland1-a region.
Customers may not be able to create, read, update, and delete operations. VM operations may also be impacted.
We are working with our Storage vendor on a resolution currently.
Posted Feb 20, 2026 - 12:59 UTC
This incident affected: Storage (Shared Disks).