Crusoe Cloud Console Intermittently Inaccessible

Incident Report for Crusoe Cloud

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 16:38 UTC

Update

The issue is resolved and Cloud Console is accessible and functioning as expected.
Posted Nov 18, 2025 - 16:37 UTC

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 14:28 UTC

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 14:28 UTC

Investigating

We are currently investigating an issue affecting access to the Cloud Console UI and API. Users may be unable to log in to our cloud services or access the management dashboard.
Posted Nov 18, 2025 - 12:48 UTC
This incident affected: API and UI.