VM creation and start operations in the us-southcentral1-a and eu-iceland1-a regions have been functioning normally for several hours. Our Engineering teams have addressed the underlying issue and a permanent fix is being prepared for deployment to prevent recurrence. Existing running workloads and resources remained fully operational throughout the incident.
We apologize for any inconvenience this may have caused.
Posted May 19, 2026 - 01:19 UTC
Monitoring
The issue affecting the ability to create and start Virtual Machines in the us-southcentral1-a and eu-iceland1-a regions has been mitigated. VM creation and start operations are functioning normally. No customer impact has been observed as of 14:00 UTC. Our Engineering teams continue to monitor both regions closely and are working on a permanent fix to prevent recurrence.
We apologize for any inconvenience this may have caused.
Posted May 18, 2026 - 14:34 UTC
Update
We have identified the underlying issue affecting the ability to create and start Virtual Machines in the us-southcentral1-a and eu-iceland1-a regions. Our Engineering teams are actively working on recovery. Some customers may still be experiencing impact while this work continues. Existing running workloads and resources remain fully operational and are not impacted. We will provide a further update as soon as more information becomes available.
Posted May 18, 2026 - 11:27 UTC
Identified
We are investigating an issue affecting the ability to create and start Virtual Machines in the us-southcentral1-a and eu-iceland1-a regions. Existing running workloads and resources remain fully operational and are not impacted. Our Engineering teams are actively working on recovery. We will provide an update when more information is available.
Posted May 18, 2026 - 08:24 UTC
This incident affected: GPU Virtual Machines (us-southcentral1, eu-iceland1).