Connectivity issues impacting compute instances in us-east1-a

Incident Report for Crusoe Cloud

Update

We are continuing to investigate this issue.
Posted May 20, 2026 - 03:51 UTC

Investigating

We are investigating a networking issue in the us-east1-a region affecting connectivity to a subset of compute hosts. Affected virtual machines may appear in an unspecified state or be unreachable over the network. Managed Kubernetes clusters in the region may also report nodes as Not Ready. Container Registry operations in the region, including image push/pull and repository management, are also impacted.

Engineering is engaged and actively working to identify the cause and restore service. We will provide updates as we have more information.
Posted May 20, 2026 - 01:37 UTC
This incident affects: GPU Virtual Machines (us-east1), Container Registry (Container Registry), and Networking (VPC Networking).