Managed Inference Services Inaccessible - Foundry and BYOM

Incident Report for Crusoe Cloud

Resolved

Service has been fully restored. We have identified the root cause and are taking steps to prevent recurrence.
Posted May 10, 2026 - 18:19 UTC

Investigating

We are investigating an issue affecting access to Crusoe Managed Inference, including Intelligence Foundry and Bring Your Own Model (BYOM). Customers may be unable to reach inference endpoints or send requests to the service. Engineering is actively working on recovery. We will provide an update when more information is available.
Posted May 10, 2026 - 14:41 UTC